SECRET OF CSS

Cisco reports vulnerabilities in products including email and web manager


Cisco has issued alerts for a vulnerability found in its email security and web management products that could allow an authenticated remote actor to retrieve sensitive information from an affected device.

An advisory issued by Cisco this week outlined that the vulnerability—detected in the web management interface of Cisco Secure Email and Web Manager, known formerly as Cisco Security Management Appliance (CSMA), and Cisco Email Security Appliance (ESA)—allows an authenticated actor to extract sensitive information through a Lightweight Directory Access Protocol (LDAP) server connected to the affected device.

This vulnerability is due to a design oversight in the querying process, according to Cisco. LDAP is an external authentication protocol for accessing and maintaining distributed directory information services on the public internet or corporate intranet.

No public exploitation discovered (yet)

The vulnerability was found during internal security testing and until the time of publishing the advisory Tuesday Cisco’s team was unaware of any public announcement or exploitation of the vulnerability, the company said.

According to the advisory, the vulnerability has received a 7.7 CVSS score and has no workarounds. The vulnerability, with bug IDs CSCvz20942 and CSCvz40090 for virtual and hardware appliances, respectively, can be exploited provided they:

  • Are running a vulnerable release of Cisco AsyncOS Software
  • Are configured to use external authentication
  • Are using LDAP as an authentication protocol

The external authentication is disabled by default and can be checked by navigating to System administration>Users> External authentication.

Cisco confirmed that the vulnerability doesn’t affect Cisco Secure Web Appliance, formerly known as Cisco Web Security Appliance (WSA), a hardware plug-in for the company’s secure web gateway (SWG).

Cisco has released free software updates that address the vulnerability, and can be obtained by customers with service contracts for regular software updates. Customers with no valid service contracts, or who acquired products via third-party point-of-sales, are advised to source the fixed software by contacting Cisco TAC (Technical Assistance Center).

Vulnerabilities have CVSS scores ranging from 5.4 to 9.1

Cisco also revealed an additional three vulnerabilities with CVSS scores ranging from 5.4 to 9.1.

The vulnerabilities include one (CVE-2022-20829) in the Cisco Adaptive Security Device Manager (ASDM) and Adaptive Secuirty Appliance (ASA) with a CVSS score of 9.1. This was deemed moderately severe, despite a high CVSS score, due to its requirement for administrative privileges from the attacker, and its relatively limited target. The vulnerability has received partial patching that requires updating both ASA software and ASDM.

The second Vulnerability (CVE-2022-20828) is found in the Command Line Interface (CLI) parser of the Cisco Firepower Software for Adaptive Security Appliance Firepower module. This bug, scored at 6.5 CVSS, can allow an authenticated, remote attacker to execute arbitrary commands on the underlying operating system of an affected ASA Firepower module as the root user, according to the security advisory. Migrating to a July release that has the fix is the only resolution for the vulnerability.

Lastly, vulnerability CVE-2022-20802, found in the web interface of Cisco Enterprise Chat and Email, may allow cross-site scripting against a user of the interface for that software, and has received a severity score of 5.4. Cisco said it will resolve the vulnerability with future updates, burt did not provide a timeline for doing so.

Copyright © 2022 IDG Communications, Inc.



News Credit

%d bloggers like this: